Meeting Connection Issues in Assorted Geographies

Incident Report for Roam

Resolved

This incident has been resolved.
Posted May 20, 2025 - 09:43 EDT

Identified

We have identified an issue affecting meetings containing participants in South America and certain other geographies and are applying a fix.
Posted May 20, 2025 - 09:24 EDT
This incident affected: Meetings & A/V.