Upstream Calendar Provider Issues and Chat Slowness

Incident Report for Roam

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:37 EDT

Monitoring

We are monitoring recovery of Roam's upstream notification and calendar providers.
Posted Jun 12, 2025 - 15:26 EDT

Update

We are continuing to monitor degraded performance with Android notification delivery (https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW), affecting the speed of message sends.
Posted Jun 12, 2025 - 15:24 EDT

Identified

Roam's upstream calendar providers (Microsoft and Google) are encountering an elevated error rate, due to widespread issues across the internet, including with Google and Microsoft.

We are also experiencing elevated latencies sending chat messages.
Posted Jun 12, 2025 - 14:59 EDT
This incident affected: Chat and Calendar & Events.